Go Back   Land Rover Forums - Land Rover Enthusiast Forum > Vehicle Line Up > LR2
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-02-2012, 10:12 AM
Junior Member
 
Join Date: Feb 2012
Posts: 2
Default Sirius XM Radio Problems

We just recently purchased a 2008 LR2 and I am trying to change over my XM Radio subscription from my previous vehicle. The problem is I can't find the Radio ID # on the LR2. When starting the vehicle the radio shows that we have satellite radio, but I can't get to it to find the ID #. XM customer service hasn't been much help either. They keep telling me the same thing, turn to channel 0, but that doesn't work. Even going to the advance settings, it doesn't give me an option to see the ID #. I think, some how, the sat radio has been turned off or not ever set up and now I can't find it..... Any suggestions???
Reply With Quote
  #2  
Old 02-04-2012, 11:16 AM
horacioad's Avatar
Junior Member
 
Join Date: Mar 2010
Location: Waukesha, WI
Posts: 6
Default

This is how is found on my wifes 2011. Go to sat1, by pressing on the FM button. Press menu and turn the **** until advanced settinngs is highlighted. Push the ****. Turn the **** again until Sirius ID is highlighted. Push the **** and voila, there it is. I hope this will help you, but keep in mind that the radio is probably somewhat different on the 2008.
__________________
2011 LR2 HSE
Santorini Black/Napoli Ebonny Black Leather
Climate Comfort Package
Black Laquer Instrument Pack
Navigation
&
2010 LR4 HSE
Alaska White/Jet Black Leather
Navigation

2008 LR3 SE
Zermatt Silver/Ebony
Sirius/Cold Package
Front & Rear Parking Control/PTI

Last edited by horacioad; 02-04-2012 at 11:20 AM.
Reply With Quote
  #3  
Old 02-06-2012, 08:02 AM
Junior Member
 
Join Date: Feb 2012
Posts: 2
Default

Here is the problem. When I go to "advance setting" the satellite is not an option. I am not sure why. I was told by the dealer that this had satellite and when I turn the radio on it goes through it's displays at the beginning and "Sirius Radio" shows.....

I've had nothing but problems dealing with Sirius/XM when trying to switch it over. They pretty much gave up and sent me a separate radio to add to the vehicle, but I am not fond of that option.

Looks like I will have to contact the dealer and see what is up.
Reply With Quote
  #4  
Old 02-07-2012, 07:31 AM
horacioad's Avatar
Junior Member
 
Join Date: Mar 2010
Location: Waukesha, WI
Posts: 6
Default

ok, don't take it the wrong way, but here is the stupid question of the day..... Your truck does have Sat radio? It is weird that it doesnt show it and that you dont get the CALL SIRIUS AT 1-888.... whatever it is everytime you turn it on.
__________________
2011 LR2 HSE
Santorini Black/Napoli Ebonny Black Leather
Climate Comfort Package
Black Laquer Instrument Pack
Navigation
&
2010 LR4 HSE
Alaska White/Jet Black Leather
Navigation

2008 LR3 SE
Zermatt Silver/Ebony
Sirius/Cold Package
Front & Rear Parking Control/PTI
Reply With Quote
  #5  
Old 02-08-2012, 11:04 PM
Junior Member
 
Join Date: Dec 2011
Location: Ocean County, NJ
Posts: 24
Default

Tune to channel 184. That's the preview channel. If that comes in, you have satellite radio. If it doesn't, well, you don't.

Also, tuning to channel "0" to get the radio ID is from the XM platform. Your LR2 would have come with a Sirius radio, so the "Channel 0" thing won't work. Also, you don't really need the radio ID anyway, you can tell Sirius your VIN number and they can activate your radio from that.

By the way, they charge a fee for you to switch your account from XM to Sirius, even though it's the same company. Ask them to waive that and they will. If they don't cancel your XM account first and register your Sirius account as a new one.
Reply With Quote
  #6  
Old 06-25-2014, 08:23 PM
Junior Member
 
Join Date: Jun 2014
Posts: 2
Default Solved!

I know this post is a couple years old, but I found it while trying to fix the same issue on my LR2....


I've been trying to fix this issue on my 09 LR2 for some time now. I had the same symptoms as most others: When the radio is turned on, it had the Sirius logo so I assumed the vehicle came with it. When pushing the "FM/Digital" button, it just cycled from FM1 to FM2 over and over. I ended up buying the OEM trailer wiring harness and while installing it, found the radio/Sirius module. I was able to get the Sirius ID# off of the unit and on a whim, signed up for a 2 month free trial to see if them sending their activation signal would do anything. After a few minutes, I tried pushing the FM/Digital button a few times and low and behold - Sirius now showed up! The trick is getting to the Sirius module. It is located in the rear of the vehicle on the drivers side, behind the panel that has the light in it. To get to it, you have to remove the floor piece so you can see the spare tire, remove the bottom trim piece (where the gate latch connects), remove the black carpet deal to the left of the tire and then pull the side panel out some. You don't need to remove it completely, just enough to peer in and see the module. You will need to spin the tie down out of the way to get the panel pulled out.


Hope this helps!

Last edited by mascroft; 06-25-2014 at 08:26 PM.
Reply With Quote
  #7  
Old 06-26-2014, 07:04 AM
jafir's Avatar
Senior Member
 
Join Date: Nov 2009
Location: Arkansas
Posts: 4,656
Default

On both of my last cars with satellite radio, a 2004 acura tl and a 2006 lr3 there were able to look up my ID from my VIN.
__________________
___
Jafir

2006 LR3 SE
2006 LR3 HSE project
1987 D90 ex-mod, 2.5NA, LT77, 1.66 LT230, stock for now. 7.50R16C Michelin XZL. D1 axles, Qt diff guard, and TF +2 Prosport shocks all waiting to be installed.


Previous Rovers:
2003 Discovery S
1999 D2 SE7
1996 D1 SE7
Reply With Quote
Old 06-26-2014, 07:04 AM
 
 
 
Reply

Tags
2011, channel, complaints, controls, meh, powered, radio, range, rover, satellite, sirius, siriusxm, vbulletin, wisconsin, xm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 10:09 AM.

Copyright © Internet Brands, Inc. All rights reserved.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO ©2010, Crawlability, Inc.
LAND ROVER and its logo are the registered trademarks of Land Rover. Land Rover is not affiliated with LandRoverForums.com.

Emails Backup