Land Rover Forums - Land Rover Enthusiast Forum

Land Rover Forums - Land Rover Enthusiast Forum (https://landroverforums.com/forum/)
-   Discovery I (https://landroverforums.com/forum/discovery-i-39/)
-   -   96 discovery Transfer case shifter issue - Video included (https://landroverforums.com/forum/discovery-i-39/96-discovery-transfer-case-shifter-issue-video-included-92076/)

ihscouts 11-08-2018 05:14 PM

My guess is there is something wrong with the stick (hehe). It is a plastic ball and socket type articulation with a spring for preload, really stupid overkill for what it does. It would take Superman to bend either linkage using that type of setup. You might also have a stuck High/Low selector on the transfer case from lack of much use being that your in B'ham. It pivots radially and is a wonder to loosen without removing the linkage through the floor opening for the shifter. I like my Heep more and more....... It took me seven years to finally break and fix my tc shifter, flopped around like a wet noodle. I removed all interlocks, park and tc wise while fixing the shifter, old solenoids like to poop their coils.

whiskeynipple0088 11-09-2018 11:37 AM

I forgot about the soleniod involved that can go bad and not allow you to go to Low - I have removed mine for this reason - just rtv'd the cover back on.
You can easily see it right on top of the case once you come in from the top.
Some people use sheet metal screw to replace the rivits of the boot.

mware18 11-10-2018 02:50 PM

Console out, auto shifter out of the way and looking down on transfer case. First thing I see is cable with eye ring on the end sitting on top of t case and not connected to anything. What is this and where does it connect? It is sitting on the top near a plate with 7 screws. six around the plate perimeter and one other.

stillruns 11-10-2018 03:23 PM

Got a photo you can post looking down?

Icannap1 11-10-2018 04:49 PM

Take a picture so we see what you are seeing. PO may have installed something different aftermarket or mickey mouse something.

mware18 11-10-2018 04:55 PM

I found where the cable attaches. Found a pic on google. Also, problem with CDL lever not moving from front to back solved by removing the solenoid.

I can move freely now between locked and unlocked, low and high. I do not get any lights on the dash when I moved to locked.

Thoughts?

ihscouts 11-10-2018 05:07 PM

Check dash bulb with another known good from dash and check the TC switch/connection.

mware18 11-10-2018 06:00 PM

Here is the cable that was not attached.
https://cimg3.ibsrv.net/gimg/landrov...592255a65.jpeg

mware18 11-10-2018 06:11 PM

Where can I find the TC switch to check the switch? I removed the solenoid earlier. Is it the in front of the four bolt plate I removed for solenoid?

ihscouts 11-10-2018 06:33 PM

No, it's the one you have circled with a fake crayola......


All times are GMT -5. The time now is 11:20 AM.


© 2019 MH Sub I, LLC dba Internet Brands