Land Rover Forums - Land Rover Enthusiast Forum - View Profile: Savannah Buzz

Savannah Buzz Savannah Buzz is offline

Super Moderator

Visitor Messages

Showing Visitor Messages 1 to 10 of 31
  1. thatbaldguy
    08-04-2016 01:30 PM - permalink
    Hey Buzz... don't know if you're still active on the forum, but I live on Tybee Island and just bought an 03 disco. Brand new to LR and would love to have somebody that knows something about them take a gander. 120k miles, 3 amigos (but was told by the PO that it needed a wheel sensor). Lemme know if you're still around and wouldn't mind stopping by the next time you head out to the beach... I'll buy the beer. thanks -sean
  2. pedro_malo
    08-25-2014 07:52 PM - permalink
    I take it you are a GT fan. Can you check ou this proble I posted - I'm loosing my mind over it.

    https://landroverforums.com/forum/di...ck-park-68859/

    Thanks
  3. Jared9220
    02-13-2014 03:20 PM - permalink
    I have seen you mention a color coded wiring manual on more then one thread. I have searched the RAVE up and down and can not find anything like that. Do you have a link this mysterious wiring diagram?
  4. Richard.rover
    01-19-2014 09:12 PM - permalink
    Thanks for your help with the knock sensor wiring. Got it all fixed up and running.
  5. sayeedA
    01-14-2014 01:30 AM - permalink
    Thank you. Now this is getting over my head. I also noticed when I turn on my Headlight the LED for Radio & clock goes very dim. wonder if there is any correlations.
    I assume you are talking about RAVE manual, right? Do I need to take the radio and panel out?

    Thanks
  6. Richard.rover
    01-09-2014 09:17 PM - permalink
    Hey savannah buzz. Need your help on a knock sensor wiring. I have a disco 2 that has a wiring issue going to the rh knock sensor and as a result I have a code p0332 that it can't shake. I repaired the pink black wire but I can't find the black rave says goes to it. I noticed it was a coaxial cable. Not sure how to find that negative. Any help is appreciated. Thanks
  7. sayeedA
    01-08-2014 03:25 PM - permalink
    Hello I have a question that no one has been able to answer in this forums. I figured you may be my last resort. My Transmission temp light has been on for all time even at the start. Recently changed all the filters and Fluids the light is still there. I understand the 2 sensors and their locations. I disconnected one at a time, then both - no change the light still on. Before I replace the sensors i need to be sure. Any suggestions?
  8. Savannah Buzz
    12-16-2013 04:42 AM - permalink
    That would be a wire between the ECU and the BCM (Body Control Module), could be loose connector, etc. Locking and unlocking five times may help, also the EKA code may help. The BCM has the alarm function inside it along with a memory battery that remembers what it was doing before power was lost.
  9. Troys Cars
    12-15-2013 06:14 PM - permalink
    I changed the cooling system during that time I had removed the battery then I used a Obdm code reader and it came up with a code p1668 found out it was anti theft immobilizer do u know how to reset that?
  10. drowssap
    07-26-2013 10:28 AM - permalink
    basically the same thing line the edge of the heads with clay (cheap) then drop the intake on and start to hand tighten the bolts. remove the manifold and see if you have any places that are bare aluminum, if you do then the manifold is bottoming out and will never sit right.
    I thought is the more the heads are cut the wider the V in the intake becomes, there fore your manifold is not laying in the V, but bottoming out against the heads.

About Me

  • About Savannah Buzz
    Biography
    97 Discovery I - 173K - 1993 Mercedes 300TE 259K - 1993 F250 135K - 2007 Kia Sedona 174K
    Location
    Savannah Georgia
    Interests
    photography
    Occupation
    Maintenance manager - engineering university
    forename
    Charlie
    surname
    Williams
  • Signature
    Free download of RAVE and Rover shop & owner manuals (LR3 and older) in pdf: https://landroverforums.com/forum/ge...ing-lr3-57978/
    Workshop/electrical/owners/overhaul/ECU for Discovery, Range Rover, Freelander, LR3, and older models


    Cooling System Problems: https://landroverforums.com/forum/ge...verview-51034/

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 02-06-2016 01:50 PM
  • Join Date: 01-01-2011
  • Referrals: 2
Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.