Flashing M and S light in green - Land Rover Forums - Land Rover Enthusiast Forum
 


Discovery II Talk about the Land Rover Discovery II within.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-06-2009, 01:20 PM
Senior Member
Thread Starter
 
Join Date: Feb 2009
Location: Ouray CO
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Default Flashing M and S light in green

I have had this vehicle for about 4 months now. 2002 SE7 with 59000 miles. Twice after heavy rain storms I have come out to my car in the morning and started to find flashing green M and S lights. I follow the manual's instructions and turn the vehicle off and back on and the lights are gone. It seems that this can happen every once and a while but at what point do you decide to dig deeper? Any reason why a rain storm might trigger this or is that just a coincidence?
Reply With Quote
  #2  
Old 05-06-2009, 02:19 PM
Disco Mike's Avatar
Administrator
 
Join Date: Apr 2006
Location: Denver, Colorado
Posts: 25,712
Thanks: 0
Thanked 41 Times in 33 Posts
Default

You need to do a search for your flashing lights, no need to reanswer your question after it has been written about weekly for weeks. Once you learn more about it and then have a specific question, then get back to us.
Reply With Quote
  #3  
Old 05-06-2009, 04:06 PM
Spike555's Avatar
Senior Member
 
Join Date: Jun 2007
Location: Grand Rapids MI
Posts: 26,212
Thanks: 0
Thanked 44 Times in 29 Posts
Default

I would say that either the belt is getting wet and slipping or the plug at the trans is getting wet.
Reply With Quote
  #4  
Old 05-08-2009, 09:48 AM
Senior Member
Thread Starter
 
Join Date: Feb 2009
Location: Ouray CO
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey Disco Mike I understand your frustration but I actually had poked around at some other threads before posting. I have a general idea of some of the causes. I think I did not say what I was asking very well. Nothing looks or acts out of place as far as battery and what not. It has happened just twice after very heavy rain. So I was just curious about two things. Do Discos just have this every once in a while so if you turn it off and then back on and it is gone is it not soemthign to worry about? I had a toyaota celica that I put 320000 miles on and it had a similier type issue the whole time. Every once in a while it throw a light you would turn it off and back on and it was gone and nothing ever came of it. Again the belts and battery look pretty good. I have my 60 coming up soon so many of these issues will be reviewed then. So maybe this whole thread will be corrected with just that maintenance.
Reply With Quote
  #5  
Old 05-08-2009, 09:49 AM
Senior Member
Thread Starter
 
Join Date: Feb 2009
Location: Ouray CO
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Spike555 View Post
I would say that either the belt is getting wet and slipping or the plug at the trans is getting wet.
That seems reasonable. We are about to get pounded again with more rain so I will be curious to see if it happens after the rain.
Reply With Quote
  #6  
Old 05-08-2009, 11:10 AM
Disco Mike's Avatar
Administrator
 
Join Date: Apr 2006
Location: Denver, Colorado
Posts: 25,712
Thanks: 0
Thanked 41 Times in 33 Posts
Default

Consider tightening all your grounds and just for ,"****s and Giggles", go by your local auto parts store and have then test to verify the voltage, when the engine is off and at idle.
Reply With Quote
  #7  
Old 05-08-2009, 11:22 AM
Senior Member
Thread Starter
 
Join Date: Feb 2009
Location: Ouray CO
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Disco Mike View Post
Consider tightening all your grounds and just for ,"****s and Giggles", go by your local auto parts store and have then test to verify the voltage, when the engine is off and at idle.
10-4 good buddy
Reply With Quote
  #8  
Old 09-25-2009, 09:43 PM
Junior Member
 
Join Date: Sep 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

love is so wonderful, it helps us overcome many difficulties in our life, Thanks to love, We will feel our life more meaningful. Thanks so much to ur post and ur topic, i love it.
Reply With Quote
  #9  
Old 09-26-2009, 07:47 AM
hazletbassist89's Avatar
Senior Member
 
Join Date: Feb 2008
Location: Hazlet, NJ
Posts: 939
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by sushypmad View Post
love is so wonderful, it helps us overcome many difficulties in our life, Thanks to love, We will feel our life more meaningful. Thanks so much to ur post and ur topic, i love it.
Name:  cool-story-bro.jpg
Views: 6
Size:  51.5 KB
Reply With Quote
  #10  
Old 07-07-2010, 10:20 AM
Senior Member
Thread Starter
 
Join Date: Feb 2009
Location: Ouray CO
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just so that people that are reseraching this have another reference I eventually replaced my battery which so far has corrected the issue.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Flashing M and S green lights on dash???? Chrisinhouston Discovery II 30 04-23-2015 06:39 PM
hard shift into 2nd then flashing m and s flashing D and red shift lights importdave Discovery II 5 09-25-2014 10:18 PM
No start and the Green Transmission Lights are Flashing Joe Pundzak Discovery II 10 02-09-2013 12:49 PM
Help: Green M and S flashing and new code Jadreigo Discovery II 1 09-13-2012 07:25 PM
Flashing the green S and M lights Larry General Tech Help 5 08-22-2007 02:53 PM


Tags
2002, 99, blinking, car, discovery, flashing, forums, green, land, light, lights, rover, sale, sm, what, wheelers

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:25 PM.


LAND ROVER and its logo are the registered trademarks of Land Rover. Land Rover is not affiliated with LandRoverForums.com.