Car won't shift in automatic, but shifts great in sport mode or any special progams - Land Rover Forums - Land Rover Enthusiast Forum

Go Back  Land Rover Forums - Land Rover Enthusiast Forum > Land Rover > LR3
Reload this Page >

Car won't shift in automatic, but shifts great in sport mode or any special progams

LR3 Talk about the Land Rover LR3 within.

Car won't shift in automatic, but shifts great in sport mode or any special progams

Reply

 
 
 
  #1  
Old 08-04-2014, 04:47 PM
Junior Member
Thread Starter
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Question Car won't shift in automatic, but shifts great in sport mode or any special progams

Hi there,

I've had two weeks of crazy electrical gremlins. After multiple faults, the car not starting, and much more, I was able to fix all of these.

Now the only problem I have is that the transmission will not shift out of first gear in automatic. It drives great, but will not shift for any reason.

When put in sport mode, I can manually shift it through every gear and it drives perfectly. Same goes for any special programs modes. They all shift great.

My questions is, Where should I look, or begin to look for solutions to this problem? I feel good knowing my transmission is in great shape, but would love to fix this asap.

Any suggestions are appreciated!
 
Reply With Quote
  #2  
Old 08-04-2014, 05:47 PM
stmcknig's Avatar
Senior Member
Join Date: May 2012
Location: Austin TX
Posts: 205
Thanks: 0
Thanked 2 Times in 2 Posts
Default

I don't know if you have had any fault codes read but I vaguely recall some thread on disco3.co.uk about an issue with the steering angle sensor either needing to be recalibrated and/or replaced. Allegedly if the electronics think the vehicle is in a tight turn it won't shift gears. Which is why I think Dave asked you about tire sizes etc in your older thread....
 
Reply With Quote
  #3  
Old 08-04-2014, 06:23 PM
jafir's Avatar
Super Moderator
Join Date: Nov 2009
Location: Arkansas
Posts: 5,841
Thanked 77 Times in 77 Posts
Default

Mine behaved this way after I flashed the TCCM, but I had no way of calibrating the transfer case. After blackbox created a routine on the nanocom to do the calibration, my auto started shifting normally. This makes me wonder if your TCCM has issues. Some people have talked about opening them up and finding burned parts.
 
Reply With Quote
  #4  
Old 08-04-2014, 06:39 PM
Junior Member
Thread Starter
Join Date: May 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmmm, well tire pressures are all good. I'll check into the angle sensor.

Called the dealership today, going to have them hook it up and read any codes that might be stored on the ECU's (since nothing is appearing on my dash). I would bet it just needs to be flashed/updated or something to put it back where its supposed to be.

I'll keep looking through posts to see if I can find anything. If not, i'll update everyone on the diagnostics test soon!
 
Reply With Quote
  #5  
Old 08-04-2014, 11:36 PM
Senior Member
Join Date: Apr 2008
Posts: 1,475
Thanks: 0
Thanked 23 Times in 21 Posts
Default

Also, how are your brake lights working? - with headlights switched both on and off, if DRL is enabled

Key on, engine off, foot off brake - Can you shift from park to reverse?

Can you shift from high to low range?

I would also remove your headlight power wash relay completely, as it wasn't working correctly as your main relay before, and may cause other issues.
 
Reply With Quote
  #6  
Old 08-05-2014, 03:53 PM
Junior Member
Join Date: Feb 2013
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Check your brake lights !

Had the same problem about 1 year ago . Car would shift in sport / manual mode and would shift when in special programs . Found out it could be your brake light switch . It's located at on the on the brake peddle arm . Or one of your bulbs is bad . Maybe not the running part of the bulb but the actual brake light . When I found mine I drove to the auto store to get a replacement . On the way the dash lit up like a Christmas tree . Car lowered to bump stops . But it kept going . Replaced both bulbs even tho only one was bad. Started the car and all was good. The bulbs are a simple and easy to rule out .
 

Last edited by Nkhooter; 08-05-2014 at 03:55 PM. Reason: The bulbs are easy to rule out
Reply With Quote
  #7  
Old 07-07-2018, 04:14 AM
Junior Member
Join Date: Jul 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by mcvayrover View Post
Hi there,

I've had two weeks of crazy electrical gremlins. After multiple faults, the car not starting, and much more, I was able to fix all of these.

Now the only problem I have is that the transmission will not shift out of first gear in automatic. It drives great, but will not shift for any reason.

When put in sport mode, I can manually shift it through every gear and it drives perfectly. Same goes for any special programs modes. They all shift great.

My questions is, Where should I look, or begin to look for solutions to this problem? I feel good knowing my transmission is in great shape, but would love to fix this asap.

Any suggestions are appreciated!
I am having the same issue where my 2005 LR3 shifts fine only in sport mode but fails in regular mode. How did you end up resolving your situation? Did you resolve it? or, did you end up just driving in sport mode for an extended period? if so, how long can this last before having an issue in this mode as well? please advise!
 
Reply With Quote
  #8  
Old 07-09-2018, 10:31 PM
5280LR3's Avatar
Member
Join Date: Apr 2018
Location: Colorado
Posts: 83
Thanked 3 Times in 3 Posts
Default

Probably not going to get a reply from the original OP since the thread is 4 years old. What gear will the trans shift through in the standard mode?
 
Reply With Quote
  #9  
Old 07-11-2018, 03:20 AM
Junior Member
Join Date: Jul 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

2nd gear does not work in standard mode
so far, however, LR3 shifts well in sport mode
I have never changed fluid and it has 112,000 miles
one reputable shop told me it's too late since 2nd gear is out that changing fluid wing help.
I plan to just drive in sport mode for now. not sure what else to do
 
Reply With Quote
  #10  
Old 07-11-2018, 05:23 PM
5280LR3's Avatar
Member
Join Date: Apr 2018
Location: Colorado
Posts: 83
Thanked 3 Times in 3 Posts
Default

So you have just 1st gear in standard mode? It does not shift beyond 1st in standard mode?
 
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: Car won't shift in automatic, but shifts great in sport mode or any special progams


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.