Go Back   Land Rover Forums - Land Rover Enthusiast Forum > General Land Rover Forums > General Tech Help
Sign in using an external account
Register Forgot Password?
Search

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-16-2010, 09:29 PM
Junior Member
 
Join Date: Mar 2009
Posts: 7
Question Hard Problem Starting When Cold???

My 1998 Range rover takes 3 or 4 tries with turning the key to the ON/Off position before it starts. It will run a little longer each time until about the 4th time when the start finally catches and keeps running. Also when going up hill the engine blogs down whenever I try to accelerate. I've put new plugs and wires on it about 2 months ago. Any help would be appreciated.

Thanks,

Wydell
Email: DaleConley1@aol.com
Reply With Quote
  #2  
Old 05-17-2010, 06:37 PM
Member
 
Join Date: May 2010
Location: South Florida
Posts: 41
Talking Hard starting

BigDogg,

Both of those symptoms sound like low fuel pressure. Have you checked it? Should be around 40 psi. ibis1
Reply With Quote
  #3  
Old 05-20-2010, 07:26 PM
Junior Member
 
Join Date: Mar 2009
Posts: 7
Default

Quote:
Originally Posted by ibis1 View Post
BigDogg,

Both of those symptoms sound like low fuel pressure. Have you checked it? Should be around 40 psi. ibis1
How do I check the Fuel Pressure?

Thanks,

Wydell
WydellConley@aol.com
Reply With Quote
  #4  
Old 05-21-2010, 07:19 PM
Spike555's Avatar
Senior Member
 
Join Date: Jun 2007
Location: Grand Rapids MI
Posts: 26,210
Philip Lawrence
Send a message via Skype™ to Spike555
Default

You will need to rent a fuel pressure gauge and then find the fuel pressure test port and check the fuel pressure after it has sat overnight (before starting) and then again with the engine running.

But it sounds like a bad fuel pump.
__________________
The "Storm Trooper", 1997 Discovery with 230,000 miles, still a daily driver.
Reply With Quote
  #5  
Old 05-28-2010, 04:08 PM
Member
 
Join Date: May 2010
Location: South Florida
Posts: 41
Talking Hard starting cold?

Quote:
Originally Posted by chrisjohn20345 View Post
If your engine cranks slowly, your cold starting problem is not fuel related, but may be due to a weak battery, loose or corroded battery cables, or a weak starter.
Chrisjohn,

Where did he mention that it cranked slow? ibis1
Reply With Quote
Old 05-28-2010, 04:08 PM
 
 
 
Reply

Tags
1996, 1998, 2000, 99, cold, discovery, hard, land, landrover, problem, problems, range, rover, start, starting


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 01:30 AM.

Copyright © Internet Brands, Inc. All rights reserved.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014 vBulletin Solutions, Inc. All rights reserved.
SEO by vBSEO ©2010, Crawlability, Inc.
LAND ROVER and its logo are the registered trademarks of Land Rover. Land Rover is not affiliated with LandRoverForums.com.

Emails Backup