Freelander Talk about the Land Rover Freelander within.

Help with 05 Freelander not cranking.

  #1  
Old 04-15-2019, 02:17 PM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Help with 05 Freelander not cranking.

I just got a 2005 Landrover Freelander 2.5L V6 from someone for a good price, but I cannot get it to crank at all. I switched around the relays in the engine compartment fuse box to see if that would allow it to crank but no dice. It has 128k miles the dashboard lights up, the radio does not even come on with the key on I took a video of it which I will link below so you guys can take a look at it and give me some ideas on what could be wrong. I will note that I did hook the battery up wrong by accident because I was in a hurry and the engine fan came on and the horn started blaring. Before that the battery that was in there wouldn't start it just made the clicking sound you hear when you have a dead battery and try to start it. I was told it also doesn't have a catalytic converter. If anyone could help me that would be great thanks. Otherwise I will just sell it as a parts vehicle.

https://youtu.be/lywon8RMzRM
 
  #2  
Old 04-16-2019, 11:05 AM
Junior Member
Join Date: Oct 2017
Location: Utah
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Default

As somebody who bought a non-running freelander and spent 100+ hours getting it running, my first advice would be to walk away if you can. Freelander engines are very sensitive to vacuum leaks and their vacuum lines tend to leak a lot.
I have put almost twice what I paid for mine (I paid $1500 for it not-running) into it just in parts (although a lot of that was a dealer-only ECM) and the only reason I'm still driving it is because it mostly works at this point and I can't get much for it if I sell it. I don't know what you paid for yours, buy freelanders aren't worth much over 2k in running condition and mine at least just doesn't have a lot of get up and go and isn't that much fun to drive.

As for yours not cranking, the first thing I always check is the gear shift/gearshift indicator switch. If the car thinks it's in drive or reverse it won't even think about trying to start.
You could also try locating the starter and putting power to the starter solenoid with a jumper and seeing if you can get it to turn over that way.
My freelander is at work with my wife right now, but when she gets back for lunch in about two hours I'll go look at it and see how the dash lights compare to yours before it starts.

Fell free to PM me with other questions, this site is pretty bad about notifying me about new posts in a timely manner. I'm not the most experienced mechanic, but I have put a lot of hours into my freelander so I've figured out a few things.
 
  #3  
Old 04-16-2019, 01:59 PM
Junior Member
Join Date: Oct 2017
Location: Utah
Posts: 15
Likes: 0
Received 1 Like on 1 Post
Default

So I went out and looked at mine and here are some issues I see based on turning my car on and observing-
Your "check engine soon" light should be on when the key is on but the engine is off.
Your "check engine" light is also not coming on when you turn the key on (it should be on the opposite side of the tachometer from the "check engine soon" light and should turn off when the ABS and SRS lights turn off. It is possible that somebody pulled the bulbs to hide an issue, so I would get a scan tool and check codes ASAP. I use a cheap bluetooth one from Amazon with a tablet and Torque Plus on my Freelander.
Your temperature gauge is maxed out, hence the red led. That probably means the sensor is bad.
Your traction control and hill decent lights are both on, that often means the brake pedal switch has gone bad. Those should turn off after a few seconds.
Your odometer display is not showing what gear you are in, so I would definitely check the gear shift position switch. If the car doesn't know what gear it is in, it won't turn over.

Key on, engine off. The battery, check engine soon, and oil pressure lights are the only ones that should be on here (and the hand brake light if it is pulled up). Note the park indicator on the left side of the odometer display.

Engine running, all lights off.
 
  #4  
Old 04-19-2019, 08:56 PM
Junior Member
Thread Starter
Join Date: Apr 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default Changed Mega fuse, will crank now won't start.

I changed the Mega Fuse and it will now crank, but it refuses to start, the gas tank if I tapped the right thing sounds hollow, so I put like about 3 gallons in and it still refuses to start. I have tried moving the shifter when trying to start it, and I have tried starting it in neutral etc still won't start. Tried with some starting fluid though may not be spraying close enough to catch.

Also I did get 7 or 8 codes today pretty much all were misfires but 2 were about the catalytic converter.

Also the service engine light soon comes on now, and the oil pressure Guage light doesn't come on and the needle is at the other side now, along with the car on a grade icon is off.
 

Last edited by Roverish; 04-19-2019 at 09:05 PM.
  #5  
Old 04-19-2019, 10:16 PM
Pavilion's Avatar
Member
Join Date: Apr 2019
Location: Torrington, Ct.
Posts: 46
Received 10 Likes on 8 Posts
Default

Hi there. sounds like you bought a pig in a poke. Before I can try to help, I need more info. You say you got some codes some how. 7 or 8? What codes did you get? This is the info you need to interpret. Also, a word of warning, hooking up the battery backwards could fry an ecu so be prepared. You said the cat was removed, well then the engine is prob trying to run rich or lean and this will cause starting issues. The computer relies on data from the the o2 sensors to set fuel mixture which it will now not have or the data will be incorrect as the cat is missing. It sounds like somebody has tried to bypass these systems to avoid buying a cat. this is a big hint. Your over all issues will not be found until we go through every system Im afraid. Give us the codes at least or the notices your scanner posted...ie evap system failure, o2 sensor 2 bank 1 heater failure, cat efficiency low, cam sensor 1 over voltage etc etc. that sort of thing. I will try to help. Where are you btw?
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jahaddow
General Tech Help
4
10-24-2013 01:54 AM
surfari
Discovery I
4
12-03-2011 05:15 PM
lsubayoubengalz
LR3
1
08-20-2011 06:27 PM
sparky
Discovery II
5
07-07-2009 02:54 PM
dartery
Discovery II
6
04-18-2009 04:26 PM


Thread Tools
Search this Thread
Quick Reply: Help with 05 Freelander not cranking.


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.