Cranks but no start 2010 LR4 5.0 - Land Rover Forums - Land Rover Enthusiast Forum

Go Back  Land Rover Forums - Land Rover Enthusiast Forum > Land Rover > LR4
Reload this Page >

Cranks but no start 2010 LR4 5.0

LR4 Talk about the Land Rover LR4 within.
Sponsored by:
Sponsored by:

Cranks but no start 2010 LR4 5.0

Reply

 
 
 
  #1  
Old 06-11-2018, 05:30 PM
Junior Member
Thread Starter
Join Date: Jun 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Cranks but no start 2010 LR4 5.0

2010 lr4 cranks but no start. Have spark and compression but no fuel. i have fuel pressure but injectors aren't firing.
 
Reply With Quote
  #2  
Old 06-12-2018, 06:38 PM
Senior Member
Join Date: Aug 2013
Location: Boston, USA
Posts: 278
Thanked 21 Times in 20 Posts
Default

Did you pull the codes? If you post them up here people may be able to help
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
lowndes
General Range Rover Discussion - Archived
0
10-30-2015 09:14 AM
dmatranga
Discovery II
6
02-05-2013 01:27 AM
jrkstore43
Discovery II
16
09-28-2012 05:16 PM
texmanmoore
Discovery I
7
12-05-2010 01:45 PM
jennina1
Discovery II
20
08-15-2009 10:45 AM


Thread Tools
Search this Thread
Quick Reply: Cranks but no start 2010 LR4 5.0


Advertising
Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.