Cranks but no start 2010 LR4 5.0 - Land Rover Forums - Land Rover Enthusiast Forum
 


LR4 A forum for the new Land Rover LR4
Sponsored by:
Sponsored by:

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 06-11-2018, 04:30 PM
Junior Member
Thread Starter
 
Join Date: Jun 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Cranks but no start 2010 LR4 5.0

2010 lr4 cranks but no start. Have spark and compression but no fuel. i have fuel pressure but injectors aren't firing.
Reply With Quote
  #2  
Old 06-12-2018, 05:38 PM
Senior Member
 
Join Date: Aug 2013
Location: USA
Posts: 185
Thanked 14 Times in 13 Posts
Default

Did you pull the codes? If you post them up here people may be able to help
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2010-2012 Range Rover vs 2010 LR4 lowndes Range Rover 0 10-30-2015 08:14 AM
Discovery II cranks but no start (doesn't / won't start) dmatranga Discovery II 6 02-05-2013 12:27 AM
Dead on road...cranks and cranks, won't start... jrkstore43 Discovery II 16 09-28-2012 04:16 PM
engine cranks and cranks , hard to start when cold texmanmoore Discovery I 7 12-05-2010 12:45 PM
cranks, cranks...nothing - $150 jennina1 Discovery II 20 08-15-2009 09:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 11:21 PM.


LAND ROVER and its logo are the registered trademarks of Land Rover. Land Rover is not affiliated with LandRoverForums.com.
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.