Incontrol Touch pro Issues - Land Rover Forums - Land Rover Enthusiast Forum

New Discovery V Talk about the new Land Rover Discovery 5

Incontrol Touch pro Issues

Reply

 
 
 
  #1  
Old 10-16-2017, 02:24 PM
NewDiscoOwner's Avatar
Junior Member
Thread Starter
Join Date: Oct 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Incontrol Touch pro Issues

2017 Discovery HSE Si6

I am have a host of issues with my incontrol system from intermittent system freezing with restarts while driving and the incontrols apps connection dropping. I have gone 3 days without connectivity to my incontrol apps with no access to my iPhone music for that time or any of my other incontrol app features. I have read others are having problems as well and my dealer conveniently canít reproduce these issues when it is in the shop.

I am trying to figur out my ICTP version information and I found a few version numbers in the incontrol apps version page that may relate to the ICTP software version. Can anyone comment if their version information is the same as mine?

 
Reply With Quote
  #2  
Old 10-17-2017, 08:37 AM
pendergastjm's Avatar
Junior Member
Join Date: Jun 2017
Posts: 22
Thanked 0 Times in 0 Posts
Default

I have the same version numbers as you. Make sure your iPhone/iPod is not auto locking. This seemed to help me. I still have issues when I stop the car for gas/coffee and then start it back up. Has a hard time recognizing that my iPod is still connected via the USB port. Once this happens the only way to get it to recognize the iPod is there is to turn the vehicle off again, give it time to reset then start up again. Once in awhile I can get it to recognize the iPod by rebooting the iPod. In-Control Apps seems to be a bit buggy.
 
Reply With Quote
  #3  
Old 10-18-2017, 01:29 PM
NewDiscoOwner's Avatar
Junior Member
Thread Starter
Join Date: Oct 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by pendergastjm View Post
I have the same version numbers as you. Make sure your iPhone/iPod is not auto locking. This seemed to help me. I still have issues when I stop the car for gas/coffee and then start it back up. Has a hard time recognizing that my iPod is still connected via the USB port. Once this happens the only way to get it to recognize the iPod is there is to turn the vehicle off again, give it time to reset then start up again. Once in awhile I can get it to recognize the iPod by rebooting the iPod. In-Control Apps seems to be a bit buggy.
Thanks!

I did sit with lead technician at the dealership today and showed him all the issues. He seemed pisses that he had to deal with this again, blamed the company and suggested I contact them to complain. Which I already did several days earlier. I got a message back saying they would have someone contact me, but I havenít heard anything yet.

I agree that it almost always happens to me when I make a short stop, like for gas as you indicated. But my issue is more severe where I canít connect even after the car is restarted after sitting all night. I went 3 days with no connectivity then it worked as expected for a whole day. The latest is that it connects for up to 15 seconds on a song and then drops connectivity and the song skip steering wheel controls does not work for iPhone music.

When I lose connectivity to incontrol apps about 30% of the time my phone also stops charging so also loses power. I have it in the shop again,3rd time in a month. And I am going to keep hammering them until this crap gets fixed. I spend a lot of my ride distracted trying to get the phone to connect by plugging in and unplugging trying to make it connect.

I cant set my phone to not auto-lock and bypass security if that is what you are suggesting but if it is connected it wonít auto lock for me. It only auto locks when it isnít connected.
 
Reply With Quote
  #4  
Old 10-24-2017, 08:23 AM
Junior Member
Join Date: Oct 2017
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have similar issues to you, and had similar issues in my 2 previous Jaguar XF-S that had similar issues over the last 18 months. ICTP is very buggy in my opinion, i get full loss of audio on all inputs from time to time that require an engine shut down to rectify

I also think some of the problems are iOS 11 related as (like song titles not displaying) so I'd give them time for that to stabilize.

Even resorting to Bluetooth hasn't really worked for me, I get drop outs every few minutes, that I've tracked down to being connected to an apple watch at the same time. if I put the watch in flight mode, the problems go.
 
Reply With Quote
  #5  
Old 12-05-2017, 08:26 AM
pendergastjm's Avatar
Junior Member
Join Date: Jun 2017
Posts: 22
Thanked 0 Times in 0 Posts
Default

As an update, I had the software in the vehicle updated at the dealer when I took it in for the 15,000 mile check-up. That seems to have corrected most, if not all, the issues I was having.
 
Reply With Quote
  #6  
Old 12-08-2017, 05:21 PM
Junior Member
Join Date: Jun 2017
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by pendergastjm View Post
As an update, I had the software in the vehicle updated at the dealer when I took it in for the 15,000 mile check-up. That seems to have corrected most, if not all, the issues I was having.
What is the version number they updated you to?
 
Reply With Quote
  #7  
Old 12-11-2017, 12:11 PM
pendergastjm's Avatar
Junior Member
Join Date: Jun 2017
Posts: 22
Thanked 0 Times in 0 Posts
Default

Originally Posted by argonpaul View Post
What is the version number they updated you to?
The app on my phone is now version 2.7.0.57
 
Reply With Quote
  #8  
Old 12-28-2017, 12:17 AM
Junior Member
Join Date: Jan 2013
Location: Dallas
Posts: 13
Thanked 0 Times in 0 Posts
Default Exact Issues

I'm taking my Discovery HSE LUX in tomorrow and hopefully the software update on their end will resolve the same issues you've been having. But I also have issues with the intelligent auto start/stop feature that never works anymore, built-in navigation audio does not work all the time, rear panel is loose and not fully sealed, slow reaction of the tailgate button, sluggish acceleration, and spare tire low on air. I just want all this to be fixed so I can start the new year on a positive note.
 
Reply With Quote
  #9  
Old 12-28-2017, 12:35 AM
Junior Member
Join Date: Jan 2013
Location: Dallas
Posts: 13
Thanked 0 Times in 0 Posts
Default

Originally Posted by pendergastjm View Post
The app on my phone is now version 2.7.0.57
So you're saying they updated the InControl App on your phone? Did they update any software for the vehicle? I have the same iPhone InControl App version 2.7.0.57 like you but still have my issues.
 
Reply With Quote
  #10  
Old 01-03-2018, 11:52 AM
pendergastjm's Avatar
Junior Member
Join Date: Jun 2017
Posts: 22
Thanked 0 Times in 0 Posts
Default

Originally Posted by LR4Top View Post
So you're saying they updated the InControl App on your phone? Did they update any software for the vehicle? I have the same iPhone InControl App version 2.7.0.57 like you but still have my issues.


Yes, they updated the software in my vehicle.
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mark0006
New Discovery V
0
12-07-2016 05:42 PM
pep100
LR3
1
11-14-2008 11:24 AM
kfordric
Discovery II
2
07-13-2005 10:37 AM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory