Range Rover P38 (2nd Gen) Talk about the Land Rover Range Rover P38 within.

Driver side coil has no spark

  #1  
Old 11-04-2018, 02:49 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Driver side coil has no spark

I have a 2000 Range Rover that I just replaced head gaskets. After putting it all back together, the driver side coil has no spark. Replaced both coils and the CPS and that still did not fix the problem. Any help would be appreciated.
 
  #2  
Old 11-05-2018, 12:10 AM
Junior Member
Join Date: Apr 2017
Location: PDX
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ground wire for the coil pack attached?
 
  #3  
Old 11-05-2018, 07:30 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Checked the voltage on the input to the coils. Both coils have 12.6 volts on the center lead. The working coil has 0.1 volts on both outer pins. The non working coil had 6.3 volts on both outer pins. Maybe ECU?
 
  #4  
Old 11-17-2018, 09:40 AM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Still can't figure out what is wrong. Leaning towards bad ECU, but would like other thoughts.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
post42
Discovery II
1
09-10-2013 03:33 PM
jafir
Discovery II
15
06-19-2013 12:29 PM
Princess
Discovery II
6
09-15-2009 08:02 PM
BlueDisco
Private For Sale/Trade Classifieds
0
02-19-2007 02:50 AM


Thread Tools
Search this Thread
Quick Reply: Driver side coil has no spark


Advertising
Featured Sponsors
Vendor Directory

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.