Discovery I Talk about the Land Rover Discovery Series I within.

Sunroof issues, more and more issues!!... Help!! :(

  #1  
Old 04-12-2017, 07:41 PM
Junior Member
Thread Starter
Join Date: Feb 2017
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default Sunroof issues, more and more issues!!... Help!! :(

Hey all,

So i got me 98 Disco 1 about 3 months ago i knew it had sunroof issues when i got it. The rear was taped up i assumed it leaked and i could fix that by just cleaning the drain tube. The front just didnt work, i heard just a click when pressing the button this click came from the ECU but no dice no movement.

As far as the rear motor it will open all the way and go forward all the way till it hits but the rear of the glass will not drop back down into position. Any ideas why??

.................................................. ...........................

WHAT I DID.....for the front

Took down the overhead stowage pocket by the sun visor and disconnected all wires and switches on back except the sunroof motor and the ECU. I picked up an ECU and two used motors which i was told work (any way to test this??)........... and yes i checked the sunroof fuse under the steering wheel.

First..... i connected bth of the sunroof switches, left the old ecu in and plugged in the other two motors neither moved at all. although when pressing the switch with one of the new motors attached, the clicking from the ECU was continuous while holding the switch where as before it was a singular click.

Second..... i repeated the process with the new ECU Same story here no dice. and still continuous clicking with that one motor.

Third..... i tried plugging the front sunroof connector into the rear sunroof switch (the rear does move but still doestn close all the way remember but it confirms the switch does work) and tried it with every combo of the first step and second step basically just tried switching all the parts while using both switches so i could to see if any combo worked. none did. still no dice on the front sunroof but the rear was good with either switch and with both ECUs.

Fourth..... I hooked up a tester bulb to the front sunroof connector pins and nothing lit up, tested it with the dome light and the rear sunroof connector pins and got a light so its not the bulb at least. but nothing lit up

Fith..... i gave up and called it a night
.................................................. ...............................................

IN SUMMARY

With testing the new motors ( i did not refit them into the mount just plugged it in and hit the switch to test if it would turn). even with the new ECU i cant get the front sunroof motors to do anything (all 3) with either ECU.

Does anyone have any suggestions as to what could be stopping the motor from getting power or something along those lines?
 
  #2  
Old 04-19-2017, 09:49 AM
Senior Member
Join Date: Oct 2013
Location: Central Minnesota
Posts: 850
Received 34 Likes on 34 Posts
Default

just a guess but... corroded connector or bad wires at the connector, or maybe the motor needs to be attached to the body (grounded) through the outside of the case to work??
 
  #3  
Old 04-19-2017, 10:07 AM
Junior Member
Thread Starter
Join Date: Feb 2017
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default

i tried turning it with an allen wranch and no go. it wont budge. took it apart cleaned it and put it back together and not working. the parts will all turn individually when apart but when i re- assemble the motor it must be binding up somehow. not sure why. i followed these steps and re assembled exaclty. still binds up and wont budge with the allen wrench.

https://www.landyzone.co.uk/land-rov...-motor.271380/
 
  #4  
Old 04-20-2017, 01:02 AM
Icannap1's Avatar
Senior Member
Join Date: Mar 2015
Location: OC CA
Posts: 151
Likes: 0
Received 30 Likes on 29 Posts
Default

There is 2 small white plastic square guides, one on both front ends of the sunroof guides that slide on the vertical tracks, if the white plastic guides are missing or cracked it will cause it to bind. The plastic guides is what slides one the vertical black track and vents the sunroof on the first stage then slides back on the second stage when opening, best bet is to take it apart and check the guides, and also check that the end of the black plastic cable track is not cracked at the end. If one of the plastic cables has a cracked end it will bind and the ECU will just click as it see's to much resistance to move the sunroof and clicks off the circuit to protect the ECU.
 
  #5  
Old 04-20-2017, 01:06 AM
Icannap1's Avatar
Senior Member
Join Date: Mar 2015
Location: OC CA
Posts: 151
Likes: 0
Received 30 Likes on 29 Posts
Default

Also once assembled leave the four screws holding the glass to the vertical track slightly loose open the sunroof with the switch then close it once closed tighten the four screws that will make sure that the sunroof glass is aligned with the track and motor.
 
  #6  
Old 04-20-2017, 07:48 AM
Junior Member
Thread Starter
Join Date: Feb 2017
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by Icannap1 View Post
There is 2 small white plastic square guides, one on both front ends of the sunroof guides that slide on the vertical tracks, if the white plastic guides are missing or cracked it will cause it to bind. The plastic guides is what slides one the vertical black track and vents the sunroof on the first stage then slides back on the second stage when opening, best bet is to take it apart and check the guides, and also check that the end of the black plastic cable track is not cracked at the end. If one of the plastic cables has a cracked end it will bind and the ECU will just click as it see's to much resistance to move the sunroof and clicks off the circuit to protect the ECU.
they move back and forth fine now there are 2 little pin i had to press in to get the rear to work now but i can manually open and shut the front if i just attach the gears with no bell housing or worm gear. i think my issue all along is that the motor is just seized up still working on getting it moving.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
akilbrid
Discovery II
20
08-20-2017 12:18 AM
slabrat
Discovery II
0
07-05-2013 01:02 PM
BigRed98
Discovery II
4
06-21-2010 12:30 AM
yukonridin23
General Range Rover Discussion - Archived
2
10-26-2009 11:14 PM
Bryan H
Discovery II
11
02-12-2009 10:59 PM


Thread Tools
Search this Thread
Quick Reply: Sunroof issues, more and more issues!!... Help!! :(


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.