Discovery II Talk about the Land Rover Discovery II within.

Weird Sunroof Issue

  #1  
Old 07-05-2018, 06:57 AM
Junior Member
Thread Starter
Join Date: Jul 2008
Posts: 10
Likes: 0
Received 1 Like on 1 Post
Default Weird Sunroof Issue

Hey Guys,

I was wanting to see if anyone has come across this issue in the past and if so what did you do to fix it?

I got in and hit my open front sunroof button (vent position) like every morning and it didn't do anything, when I hit the open the rear sunroof button (vent position) they both opened together to the vent position. Then I hit the front sunroof button to fully open the sunroof (nothing happened) and then when I hit the button to fully open the rear, they both opened together again. The same thing happened when I went to close them, the front did nothing but the rear seemed to control both. Then I tried opening the rear first, when I did this just the rear opened and then when I hit the front button, it would not do anything until I hit the rear button.

Fast forward a week, both sunroofs had been opening and closing even though the switches are acting like I mentioned before. This morning I when I got to work I cannot get the front sunroof to close. The rear functions normally and I can hear the front one trying to move (you can hear the motor attempting to move but nothing happens). I manually close the sunroof via the access panel and it closes without resistance so I know it has not jumped the track. Then just to see, I hit the open button and it opens like nothing has happened but then would not close back.

Does anyone have any idea what is going on here? I do not know if I should be looking at the switches, the ecu for the sunroofs or the front motor itself?

Any help would be appreciated!
 
  #2  
Old 07-05-2018, 08:35 AM
ahab's Avatar
Senior Member
Join Date: Apr 2018
Location: SE PA
Posts: 288
Received 37 Likes on 32 Posts
Default

You can try swapping the switches to see if the behavior changes.
 
  #3  
Old 07-05-2018, 08:47 AM
Senior Member
Join Date: Aug 2013
Location: Huntington Beach CA
Posts: 6,268
Received 570 Likes on 513 Posts
Default

Sounds like the sunroof ECU
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Craig Carloss
LR2
1
10-19-2017 09:31 PM
akilbrid
Discovery II
20
08-20-2017 12:18 AM
Atlrover89
Discovery II
3
01-11-2016 06:55 AM
BigRed98
Discovery II
4
06-21-2010 12:30 AM
khtemple
Discovery II
9
09-14-2006 06:00 AM


Thread Tools
Search this Thread
Quick Reply: Weird Sunroof Issue


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.