Help! Wiper issues - Land Rover Forums - Land Rover Enthusiast Forum

Forum Help & Suggestion Center This section is NOT for vehicle technical questions. This section is for problems or suggestions for the forum itself.

Help! Wiper issues

Reply

 
 
 
  #1  
Old 10-09-2017, 11:51 AM
gar
gar is offline
Junior Member
Thread Starter
Join Date: Apr 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help! Wiper issues

Well the snow is falling in Colorado and once again when I start my truck up in the AM the wipers are not working . After the truck gets warm I can get it to work in the low continous setting. This morning I heard the relay click in the intermittant mode but the wiper did not move. Please help. I need to tell you I am not a mechanic and my mechanical skills are luke warm at best. I want to avoid the mechanic if I can.
 
Reply With Quote
  #2  
Old 10-10-2017, 07:02 AM
Senior Member
Join Date: Oct 2016
Posts: 210
Thanked 19 Times in 18 Posts
Default

I would guess a wiper motor park switch which is part of the wiper motor. I had to replace mine, it's pretty basic the hardest part is removing the plastic cowl piece that runs along the bottom of the windscreen behind the wiper arms
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bcolins
Discovery II
10
02-02-2014 09:40 PM
siegrisd
Discovery II
5
02-17-2010 08:19 PM
LambChop
Discovery II
11
12-18-2008 04:41 PM
millejdq
Discovery II
3
12-06-2007 12:23 PM


Thread Tools
Search this Thread
Advertising
Featured Sponsors
Vendor Directory