Range Rover P38 (2nd Gen) Talk about the Land Rover Range Rover P38 within.

2000MY (bosch) P38 Range Rover - no start

  #1  
Old 11-27-2018, 10:11 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 4
Received 0 Likes on 0 Posts
Default 2000MY (bosch) P38 Range Rover - no start

I have purchased a 2000MY P38 Range Rover - the 4.6 litre engine has the bosch engine management system.
The previous owner let the car battery go flat and when I hook up a good battery to it it gives me a message about entering a code etc.

What do I do to get it working properly?
Any and all help appreciated!

 
  #2  
Old 11-27-2018, 10:17 PM
ArmyRover's Avatar
Super Moderator
Join Date: Jun 2008
Location: Augusta, GA
Posts: 7,405
Received 615 Likes on 574 Posts
Default

The code it's asking for is most likely for the radio. Do you have fuel pressure, and spark?
 
  #3  
Old 11-27-2018, 11:00 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 4
Received 0 Likes on 0 Posts
Default

Originally Posted by ArmyRover View Post
The code it's asking for is most likely for the radio. Do you have fuel pressure, and spark?
No, it doesn't get anywhere near that far!
I am well aware of how to code a radio back into a truck BECM.

Like I posted, when the ignition key is turned to ignition, the message centre asks for the code.
The truck battery was left flat for months and the BECM has lost all settings possibly the key remote codes etc.
 
  #4  
Old 12-03-2018, 03:58 PM
Junior Member
Join Date: Dec 2011
Posts: 2
Likes: 0
Received 1 Like on 1 Post
Default

hi daniel; did you start the engine yet ?
usually with new or charged battery installed the instrument cluster will show "engine disable press remote" message if the remote working then by pressing lock/unlock and start the engine also you can do the lock/unlock from the door, i used to do that with both cars one by remote and the other mechanically from the door as i had battery drainage for months. so try to ignore the code and see what happen. i never see any code on the message display for almost 10 years of ownership.
 
The following users liked this post:
Daniel1957 (12-03-2018)
  #5  
Old 12-03-2018, 04:47 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 4
Received 0 Likes on 0 Posts
Default

Yes thank you ma7amad

I left the battery connected and played around with the remote lock and unlock and similarly with key in door.
I then tried and the engine fires instantly.
The truck had been parked up with no battery for 2.5 years.
It now behaves perfectly.
Jaguar Land Rover come back to me with the EKA code but I never needed it.
The only codes that now come up is a message that fuse 8 is missing and that the EAS is on manual.
And the climate control display is blank.
More investigations required for those 3 issues.

My next task is to remove the coil kit and replace the factory EAS.
The previous owner had spent $1,000 putting in a coil suspension kit - what a goose!
It completely spoils the ride of the truck,
I am now sourcing air bags, sensors, EAS controls and air compressor.
 
  #6  
Old 12-05-2018, 09:59 PM
Fastercat's Avatar
Senior Member
Join Date: Nov 2017
Location: Amherstburg Ontario
Posts: 399
Received 41 Likes on 35 Posts
Default

Daniel where are you located?
 
  #7  
Old 12-05-2018, 10:46 PM
Junior Member
Thread Starter
Join Date: Nov 2018
Posts: 4
Received 0 Likes on 0 Posts
Default

Located Hunter Valley, NSW, Australia
 
  #8  
Old 12-09-2018, 02:39 PM
Fastercat's Avatar
Senior Member
Join Date: Nov 2017
Location: Amherstburg Ontario
Posts: 399
Received 41 Likes on 35 Posts
Default

Sorry Daniel Iím in Canada, a little far away for swapping parts lol
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Extinct
Discovery II
6
11-05-2018 11:38 AM
toomuchstuff
Private For Sale/Trade Classifieds
0
06-04-2012 08:33 PM
RROJ
General Range Rover Discussion - Archived
7
11-22-2010 06:47 AM
WARWAGON
Private For Sale/Trade Classifieds
1
05-11-2010 07:36 AM
MICK UK
General Range Rover Discussion - Archived
2
06-11-2007 10:57 PM


Thread Tools
Search this Thread
Quick Reply: 2000MY (bosch) P38 Range Rover - no start


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.